wlan blocked

Just this week I replaced the hard drive in my laptop with a solid-state drive. As part of the process I did a clean install of Fedora 28 Workstation to the drive.

The install went very smoothly but when got into using the machine (which is now so fast!) I noticed that wi-fi was disabled. I usually use my machine on a wired connection, so it was no biggie but it’s one of those nagging things that I had to fix. I had used wi-fi in the past few weeks, so it was a new problem.

With this kind of thing you work through the list of recent changes and usually it’s one of those. So I plugged in the old drive, booted to that and found that wi-fi was still unavailable. I booted to an older kernel; still nothing.

Scouring the internet for a solution I found some useful commands. This first, iwconfig, I was familiar with. It was giving:

virbr0    no wireless extensions.
virbr0-nic no wireless extensions.
lo no wireless extensions.
wlp9s0 IEEE 802.11 ESSID:off/any
Mode:Managed Access Point: Not-Associated Tx-Power=off
Retry short limit:7 RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off
enp5s0 no wireless extensions.

So the OS knew about the device. Then lspci -v gives lots of output, but of interest here is:

09:00.0 Network controller: Qualcomm Atheros AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
Subsystem: Dell Wireless 1702 802.11bgn Half-size Mini PCIe Card [AR9002WB-1NGCD]
Flags: bus master, fast devsel, latency 0, IRQ 19
Memory at f7e00000 (64-bit, non-prefetchable) [size=64K]
Capabilities: [40] Power Management version 3
Capabilities: [50] MSI: Enable- Count=1/1 Maskable- 64bit-
Capabilities: [60] Express Legacy Endpoint, MSI 00
Capabilities: [100] Advanced Error Reporting
Capabilities: [140] Virtual Channel
Capabilities: [160] Device Serial Number [ Redacted ]
Capabilities: [170] Power Budgeting
Kernel driver in use: ath9k
Kernel modules: ath9k

But the command of interest was rfkill which gave:

ID TYPE      DEVICE    SOFT      HARD
0 wlan phy0 blocked blocked
1 bluetooth hci0 blocked unblocked

The device was there, but disabled in hardware. I tried the Fn-F2 key combo and that was switching airplane mode on/off, but it never enabled wi-fi.

Further Googling found a similar problem affecting Asus devices. So following that advice I reset the BIOS (set default values on this machine) and rebooted. This fixed the problem.